• Posts by XiaoMo: 4
  • Total posts in thread: 19
Notice
This is a list of all posts made by XiaoMo in this thread. View whole thread.

XiaoMo

New member
Threads
0
Messages
4
I enabled this addon and it works great for some things but it made a large number of forums disable reply to threads. It took a long time before I realized it was this addon, when I disabled it they all went back to allow-reply. Can you help out with this? Do I have something incorrect with the addon? I do like its features if it does not break my forum. Thanks.
 

XiaoMo

New member
Threads
0
Messages
4
Good morning, and thank-you for purchasing.

This add-on adds two additional permissions: Reply to own thread, and Reply to threads by others. On installation those two permissions are set so that registered members can reply as per normal. Did you make changes to those permissions (general, or by forum)? There are no other added features to this add-on that would disallow replying.

Also can you enable the add-on again and perform an analyze permissions for a user that can not reply and let me know of the results, thank-you.

Stay safe,
Lawrence

When I installed it and enabled it I did not adjust any settings in the addon (or anywhere) globally. When it was enabled I did run permissions analyzer at the user and group levels to see if there was a permissions issue and they all showed no problem with replies etc allowed. It was quite perplexing for a while. I just considered it might be the addon when I ran out of options.
 

XiaoMo

New member
Threads
0
Messages
4
Are you still experiencing the reply problem? Does it happen to a specific forum or all forums (can you perform analyze node permissions for an effected user)? On install, the registered group is set to Yes for both permissions, are members primary user group set to registered (all members, regular, mods, and admins, should have their primary user group set to registered).

I think we have the problem figured out, and this would be a good thing to clarify for users. This a great addon if understood and applied properly.

When I installed the addon it added the additional reply own and others layers of permissionon user groups defaulting NOT to "yes" but to whatever the original single layer "reply to threads" was set to. However, when installed the addon applied the same own and others layers to "inherit" on all nodes regardless of original single layer "reply to threads" permission.

So, while the original user "reply to threads"-NO was overridden by the original node YES, the ADDON user default reply own and other - NO was not overridden by the new node added default reply own and other INHERIT, which was not a value I ever set. This of course resulted in a NO on replies. This is useful information for anyone with a larger forum I imagine. I imagine automating the installation to duplicate node permissions by default was beyond the scope of the work, and I am happy it was that instead of a bug. Thanks.
 
Top